szukanie zaawansowane
 [ Posty: 11 ] 
Autor Wiadomość
Mężczyzna Offline
PostNapisane: 6 paź 2011, o 16:06 
Użytkownik

Posty: 41
Lokalizacja: Wrocław
Witam,
w jaki sposób dołączyć obrazek do prezentacji w beamerze jako logo (chodzi o to, żeby wyświetlał się na każdym slajdzie)?
Używam takiego kodu:
Kod:
1
2
\logo{ \includegraphics[width=1.9cm]{poziom-pl.eps} }

i nic się nie dzieje.
Z kolei jak użyję kodu
Kod:
1
2
\logo(10,10){ \includegraphics[width=1.9cm]{poziom-pl.eps} }

gdzie (10,10) oznacza współrzędne lokalizacji logo, nie kompiluje się.
Z góry dziękuję za pomoc.
Góra
Mężczyzna Offline
PostNapisane: 6 paź 2011, o 18:54 
Gość Specjalny
Avatar użytkownika

Posty: 18439
Lokalizacja: Cieszyn
Może format eps nie jest rozpoznawany przez pdflatex? Rozpoznaje na pewno jpg i png. Spróbuj z innym formatem.
Góra
Mężczyzna Offline
PostNapisane: 6 paź 2011, o 20:22 
Użytkownik

Posty: 41
Lokalizacja: Wrocław
Próbowałem wcześniej i też nic. W necie na kilku stronach przeczytałem, że najlepiej używać właśnie formatu *.eps, ale jak widać powyżej, też nic to nie dało...
Może coś z tym kodem jest nie tak...
Góra
Mężczyzna Offline
PostNapisane: 6 paź 2011, o 20:36 
Gość Specjalny
Avatar użytkownika

Posty: 18439
Lokalizacja: Cieszyn
Kiedyś dodawałem logo i wychodziło. Nie mam za bardzo czasu na próby powtórzenia całej rzeczy, ale chodzi mi jeszcze po głowie, że może umieszczasz logo w złym miejscu w pliku źródłowym. Czytałeś dokumentację beamera? Zobacz tam. Punkt 8.2.5 na str. 75 (beameruserguide.pdf). Spróbuj tych dwóch komend powyżej komendy podobnej do Twojej (pgfdeclareimage itp.)
Góra
Mężczyzna Offline
PostNapisane: 6 paź 2011, o 21:28 
Użytkownik

Posty: 41
Lokalizacja: Wrocław
Użyłem tego zapisu, o którym mówiłeś (ten, którego ja użyłem też jest ok ;) ). Chodzi o to, że żeby logo wyświetlało się, trzeba dodać
Kod:
1
\insertlogo
w każdym slajdzie.
Problem jednak jest tylko częściowo rozwiązany, bo logo wyświetla się, ale bezpośrednio pod zawartością slajdu (czyli prawie zawsze będzie to inne miejsce na kolejnych slajdach). Nie wiem, jak ustalić współrzędne - jak pisałem w pierwszym poście zapis z współrzędnymi nie kompiluje się...
W dokumencie, o którym pisałeś też jest w taki sam sposób definiowanie współrzędnych, jak ja próbuję.
Góra
Mężczyzna Offline
PostNapisane: 6 paź 2011, o 21:31 
Gość Specjalny
Avatar użytkownika

Posty: 18439
Lokalizacja: Cieszyn
No to tak daleko moja wiedza beamerowa nie sięga. Zresztą logo jest zamazywane przez bloki. Widziałem w innych prezentacjach. Więcej więc nie jestem w stanie pomóc.
Góra
Mężczyzna Offline
PostNapisane: 7 paź 2011, o 10:50 
Użytkownik

Posty: 41
Lokalizacja: Wrocław
Spoko, i tak dzięki za chęci i pomoc. :)
W końcu chyba znajdę jakieś rozwiązanie, a jeśli nie, to będzie prezentacja bez logo. ;)
Góra
Mężczyzna Offline
PostNapisane: 7 paź 2011, o 13:37 
Gość Specjalny
Avatar użytkownika

Posty: 8691
Lokalizacja: Wrocław
Niewiele mam doświadczenia z beamerem, ale użyłem Twojego kodu ze swoim plikiem i ten pierwszy kompilował się i działał, a ten drugi nie.
Przy czym użyłem reszty kodu stąd: http://stuffforlife.blogspot.com/2008/1 ... ation.html
Może jest jakaś dodatkowa biblioteka zadeklarowana? Spróbuj do siebie na próbę dodać te, które są w linku.

Albo skoro się kompiluje pierwsza strona, to jest coś nie tak z jego wymiarami i gdzieś poza obszarem strony go LaTeX umieszcza? Spróbuj z innym zdjęciem (nawet w paincie byle jaki mały obrazek wyskrob).

A skąd masz, że
Kod:
1
\logo(x,y)

oznacza lokalizację?
Góra
Mężczyzna Offline
PostNapisane: 7 paź 2011, o 14:27 
Gość Specjalny
Avatar użytkownika

Posty: 18439
Lokalizacja: Cieszyn
Logo w ogóle powinno być małe. Ja w swoich prezentacjach stosowałem czasem tło z przybledzonym zdjęciem mojej uczelni, co osiągałem przez taką modyfikację

Kod:
1
2
\setbeamertemplate{background}{\includegraphics[width=\paperwidth,height=\paperheight]{moje_tlo.jpg}}
Góra
Mężczyzna Offline
PostNapisane: 8 paź 2011, o 09:40 
Użytkownik

Posty: 41
Lokalizacja: Wrocław
miki999, lokalizację wziąłem stąd:
http://kft.umcs.lublin.pl/kmur/download/prace_licencjat/mwiniarski.pdf
Zakładam, że autor bzdur nie pisze, bo to praca licencjacka.

szw1710, to jest świetny pomysł! Zrobiłem tak samo i cel osiągnięty - nie trzeba się męczyć z LaTeXowymi poleceniami, wystarczy zrobić w paincie białą przestrzeń, umieścić logo gdzieś na dole, a jak będzie w złym miejscu, bawić się do skutku. :)

Panowie, wielkie dzięki za pomoc! :)
Góra
Mężczyzna Offline
PostNapisane: 8 paź 2011, o 11:34 
Gość Specjalny
Avatar użytkownika

Posty: 18439
Lokalizacja: Cieszyn
jeth, ja Ci z kolei dziękuję za ten link do pracy licencjackiej. Przejrzę ją z zainteresowaniem, a może moje prezentacje staną się lepsze.
Góra
Utwórz nowy temat Odpowiedz w temacie  [ Posty: 11 ] 


 Zobacz podobne tematy
 Tytuł tematu   Autor   Odpowiedzi 
 [LATEX][Miktex] Jak dodać obrazek.jpg w Miktex  matma17  4
 dźwięk w prezentacji PowerPoint  Kasiula@  5
 [LaTex] jak zrobić e z kreską nad słowem Bezouta  Oleszko12  6
 [LaTeX] Rysunek  rudaa34  4
 Forum+LaTeX  Freak  4
 
Atom [Regulamin Forum] [Instrukcja LaTeX-a] [Poradnik] [F.A.Q.] [Reklama] [Kontakt]
Copyright (C) Karpatka.pl